Ragdoll Issues

I play on PlayStation 4. Whenever I return to an altar after a PvP match, I get the death sound while it's loading in. when the screen loads in, my character is laying on the ground in a ragdoll state and I cant get out of it no matter what I do. It's making the game unplayable when every time I exit pvp I have to restart the game because I get rag-dolled. I've never had issues with this before, but recently it happens to me every single time I leave pvp. What the hell is this. I love this game but I cant play it anymore because of some stupid glitch. anyone know what's going on???


  • Hi Lorien_Soldier,

    We are sorry to hear about this issue.

    Can you answer some additional questions to clear thing up, please?

    - Which platform you're using playing the game (Steam/GoG/PS4)?
    - When did it happen the first time?
    - In which region are you located/playing from?
    - The name of your Internet provider?
    - Have you tried checking file integrity and/or reinstalling the game?

    Thank you for your patience and cooperation in this matter.
  • I already told you what console, actually read the statement. it first happened about a month ago. east coast of North America. don't see how internet provider has anything to do with it. like I already said, ive tried everything. nothing fixes the issue except completely restarting the game
  • Hello Lorien_Soldier,

    Sorry for my inattentiveness and thanks for answering the questions. I have passed your report along for further review. In the meantime, if there are any other details you can share with us about the bug that would be very helpful.

    Thank you so much for your patience and continued support.
  • the issue mostly started around the birdcallers outpost. however now it happens everywhere I go
  • just to add, I have seen the same or similar on ps4 as well, and have seen ragdolls lying next to the alter while people were stuck. Also heard my character die on respawn at the alter but long before the 3d view fully loads, really weird asynchronous load time issue maybe?
Sign In or Register to comment.